Blood in urine, went away now back again

Posted , 2 users are following.

I went to the urgent care on Saturday evening as I had a lot of visible blood in my urine. The nurse said she could see right away that I had an infection (there were also bits of tissue in the sample) and gave me antibiotics.

The bleeding stopped straight away but this morning its back again after two days. I'm only three days into a seven day course of antibs. I asked about bladder cancer but she said I was too young at 45.

Has anyone here had a similar experience?

0 likes, 3 replies

3 Replies

  • Posted

    Yes, twice.....very scary, but I had a cystoscopy the first time ...all clear in bladder ... Thought it might be polyps..... but ok

    Second time a year latter another episode. Treated with antibiotics and both clear after five days.

    As I say, a bit scary, but an infection. There was also 'bits' in both episodes.

    • Posted

      Thank you. I think it's the fact the bleeding stopped for two days and is back again that is worrying me. Does that mean the antibiotics aren't working?

    • Posted

      I was given 7 days of antibiotics.....it takes 4/5 days to clear.. The blood is probably the residue.....I know it no good saying...don't worry !! but of course you will. Looking at the worst case scenario.... whatever it is , if caught early, it can be dealt with. Antibiotics will not clear it within two days.

Report as inappropriate

Thanks for your help!

We want the forums to be a useful resource for our users but it is important to remember that the forums are not moderated or reviewed by doctors and so you should not rely on opinions or advice given by other users in respect of any healthcare matters. Always speak to your doctor before acting and in cases of emergency seek appropriate medical assistance immediately. Use of the forums is subject to our Terms of Use and Privacy Policy and steps will be taken to remove posts identified as being in breach of those terms.